EGEsoll - сборник решений задач из ЕГЭ

Задача 11 администратор

Системный администратор раз в неделю создаёт архив пользовательских файлов. Однако объём диска, куда он помещает архив, может быть меньше, чем суммарный объём архивируемых файлов. Известно, какой объём занимает файл каждого пользователя.

По заданной информации об объёме файлов пользователей и свободном объёме на архивном диске определите максимальное число пользователей, чьи файлы можно сохранить в архиве, а также максимальный размер имеющегося файла, который может быть сохранён в архиве, при условии, что сохранены файлы максимально возможного числа пользователей.

В первой строке входного файла находятся два числа: S  — размер свободного места на диске (натуральное число, не превышающее 10 000) и N  — количество пользователей (натуральное число, не превышающее 3000). В следующих N строках находятся значения объёмов файлов каждого пользователя (все числа натуральные, не превышающие 100), каждое в отдельной строке.

Запишите в ответе два числа: сначала наибольшее число пользователей, чьи файлы могут быть помещены в архив, затем максимальный размер имеющегося файла, который может быть сохранён в архиве, при условии, что сохранены файлы максимально возможного числа пользователей.

Входные данные.

Download File 1

Добавлено: 17.05.26 09:13

Перейти к решению

Решение

Программа на Python:

f = open("embed.txt")
S, N = list(map(int, f.readline().split()))
a = sorted([int(l) for l in f])

added = []
while S - a[0] >= 0:
    S -= a[0]
    added.append(a[0])
    a.pop(0)
print(added, S, len(added))
print(a)

Программа выведет массив размеров файлов, которых сохранил администратор, оставшееся свободное место, количество пользователей и оставшиеся вне архива файлы.

Заметим, что у нас поместилось 650 пользователей, осталось 4 свободных места и самый тяжелый файл имеет размер 23.

Мы можем "вытащить" самый тяжелый файл и у нас станет 27 свободного места. Обратим внимание, что у нас есть файл размер 27, который мы не сохранили, он будет самым большим возможным файлом, при условии, что у нас остаётся 650 пользователей.

Ответ: 650 27

Автор - rubygem17

Объяснение

None

Назад